2014-10-18 01:45:49 +0200 <linman32> if i am only using sandbox, is it ok to clear out ~/.cabal/packages?
2014-10-18 01:08:13 +0200 <MishaC> Hello Everyone, can anyone answer this quick question. " Is there a way to view list of installed packages from ghci" The reason for asking is that I installed it, Cabal tellms me it is installed but i cannot import it.
2014-10-17 21:43:56 +0200 <Guest3151> Hey I'm getting unrecognised command: sandbox when I do `cabal sandbox init`, I've cabal-install 0.14 using 1.14.0
2014-10-17 20:50:51 +0200 <bitonic> dcoutts: is there a way to force the build log to be written to stdout, when doing `cabal install'?
2014-10-17 20:24:59 +0200 <PMode> Hi, I got pointed via a Debconf talk to hopenpgp-tools. I am trying to run hokey -lint from hopenpgp-tools from Debian Jessie/Testing 0.11.1 and also installed with cabal as 0.13 but it does not seem to output anything.
2014-10-17 20:03:36 +0200 <RlyDontKnow> jTT_: try to run cabal update to ensure the package list is fine?
2014-10-17 20:03:22 +0200 <jTT_> addendum: I tried brew unlink cabal; brew link cabal; to no avail
2014-10-17 20:02:03 +0200 <jTT_> library”.  But: “cabal install cabal” says: “All the requested packages are already installed: Cabal-1.18.1.4” Has anyone got a clue as to what this means? I suspect that perhaps homebrew installed some old version of cabal?
2014-10-17 20:02:02 +0200 <jTT_> hi, i am having a weird issue with cabal and was wondering if anyone could help: I get the following error when trying to install some packages:”xml-types-0.3.4 failed during the configure step. The exception was: user error (The package 'xml-types' requires Cabal library version >=1.19.2 && >=1.6 but no suitable version is installed.)”.  Yet, “cabal --version” shows: “cabal-install version 1.20.0.3 using version 1.20.0.2 of the Ca
2014-10-17 19:58:28 +0200 <merijn> RedNifre_: But cabal is rather effective at building libraries, so you probably *should* use it
2014-10-17 19:58:04 +0200 <merijn> RedNifre_: If you never use any other library, you don't need cabal it all, no. (Actually, you never *need* cabal)
2014-10-17 19:51:30 +0200 <RedNifre_> Hm. Do I ever need to use cabal install at all? Or could I just build my project and tell it where my local libraries are?
2014-10-17 19:05:50 +0200 <RedNifre_> Hm, I guess I should use cabal sandboxes...
2014-10-17 18:58:42 +0200 <dcoutts_> RedNifre_: you can use either the dir or the .cabal file
2014-10-17 18:56:50 +0200 <RedNifre_> do you mean cabal install /some/thing.cabal /some/other/stuff.cabal ?
2014-10-17 18:55:13 +0200 <dcoutts_> RedNifre_: e.g. cabal install ./this text
2014-10-17 18:54:27 +0200 <dcoutts_> cabal install a b
2014-10-17 18:51:50 +0200 <RedNifre_> Hm, apparently I ran into my first cabal problem.
2014-10-17 18:40:13 +0200 <jimmy99> I'm trying to install leksah on fedora and cabal fails with permission error when installing webkitgtk
2014-10-17 15:14:56 +0200 <geekosaur> there used to be an infamous one where a glitch in the dependencies for network caused cabal to come up with a 5-element, self-contrdictory constraint for unix
2014-10-17 15:13:47 +0200 <geekosaur> nshepperd, cabal in my experience does that when it gets inconsistent constraints from different dependencies
2014-10-17 15:10:41 +0200 <stupident> "cabal: At least the following dependencies are missing: network >=2.3 && <2.6 && ==2.6.0.2" How to deal with that?
2014-10-17 15:08:59 +0200 <stupident> `cabal install snap-server-0.9.4.5` failed on Windows 7, plz help
2014-10-17 13:27:27 +0200hackagebotshake-cabal-build 0.1.0 - Utility for building Shake build systems using Cabal sandboxes http://hackage.haskell.org/package/shake-cabal-build-0.1.0 (StefanKersten)
2014-10-17 13:06:29 +0200 <egasimus> I find myself trying to put together a PKGBUILD for Tidal (https://github.com/yaxu/Tidal/blob/master/tidal.cabal) which I would like to upload to the AUR for great justice.
2014-10-17 11:01:17 +0200 <mmmm_> so what happens if you go in a sandbox and "cabal install xml-types"
2014-10-17 11:00:19 +0200 <jTT_> but wouldnt cabal —version then still show the old version?
2014-10-17 10:59:30 +0200 <mmmm_> well before I have installed an updated version of cabal in a sandbox by accident and wondered why it wasn't updated
2014-10-17 10:57:53 +0200 <jTT_> mmmm_: did run cabal update
2014-10-17 10:57:33 +0200 <mmmm_> did you run cabal update before "cabal install Cabal"
2014-10-17 10:49:39 +0200 <jTT_> I suspect that perhaps homebrew installed some old version of cabal?
2014-10-17 10:48:55 +0200 <jTT_> Cabal-1.18.1.4
2014-10-17 10:48:55 +0200 <jTT_> using version 1.20.0.2 of the Cabal library But: cabal install cabal says: All the requested packages are already installed:
2014-10-17 10:48:54 +0200 <jTT_> >=1.6 but no suitable version is installed.). Yet, cabal —version shows: cabal-install version 1.20.0.3
2014-10-17 10:48:52 +0200 <jTT_> hi, i am having a weird issue with cabal and was wondering if anyone could help: I get the following error when trying to install some packages:xml-types-0.3.4 failed during the configure step. The exception was: